Selasa, 28 Oktober 2014

Cara mengkonfigure switch cisco

Filled under: , ,

Banyaknya model switch cisco dari yang terjadul hingga yang terkini membuat cara mengkonfigurasi cisco switch ini berbeda-beda, namun pada dasarnya adalah sama, perbedaannya kebanyakan hanya terdapat pada bisa tidaknya service yang kita inginkan terhadap cisco switch yang akan kita konfigure, seperti apakah switch tersebut sudah support untuk qos voip, voice vlan dan lainnya.

Disini saya akan membahas konfigurasi dasar switch cisco, untuk konfigurasi lanjutan akan dibahas pada posting selanjutnya.

Yang akan kita lakukan adalah:
Memberi hostname switch
Memberi password
Setting port line console 0
Setting port line vty 0 - 15
Setting interface untuk IP switch
Setting default gateway
Setting interface seluruh port LAN untuk user
Setting interface 1 port untuk line trunk
Membuat banner switch
Simpan konfigurasi.
Testing
Ok mari kita mulai,

1. Memberi hostname switch
Contoh disini kita akan menjadikan TELKOM_UNIVERSITY sebagai hostname swith ini._________________________________________________
Switch>ena
Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname TELKOM_UNIVERSITY

TELKOM_UNIVERSITY(config-if)#^Z

TELKOM_UNIVERSITY#
___________________________________________

2. Memberi password
Password yang kita gunakan disini adalah "telkom" tidak di enkripsi. Untuk enkripsi password akan dibahas nanti.
_____________________________________________________
TELKOM_UNIVERSITY#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
TELKOM_UNIVERSITY(config)#ena pass telkom
TELKOM_UNIVERSITY(config-line)#login
TELKOM_UNIVERSITY(config)#
______________________________________________________

3. Setting port line console 0
_______________________________________
TELKOM_UNIVERSITY#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
TELKOM_UNIVERSITY(config)#line console 0
TELKOM_UNIVERSITY(config-line)#pass telkom
TELKOM_UNIVERSITY(config-line)#login
TELKOM_UNIVERSITY(config-if)#^Z
TELKOM_UNIVERSITY#
______________________________________________________

4. Setting port line vty 0 - 15
________________________________________
TELKOM_UNIVERSITY(config-line)#
TELKOM_UNIVERSITY(config-line)#line vty 0 15
TELKOM_UNIVERSITY(config-line)#pass telkom
TELKOM_UNIVERSITY(config-line)#login
TELKOM_UNIVERSITY(config-line)#
_________________________________________

5. Setting interface untuk IP switch
Disini kita menggunakan interface vlan 1 untuk penempatan ip address switch, Ip yang kita gunakan adalah 10.123.1.10 subnet 255.255.255.0
_________________________________________________________
TELKOM_UNIVERSITY#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
TELKOM_UNIVERSITY(config)#int vlan 1
TELKOM_UNIVERSITY(config-if)#ip add 10.123.1.10 255.255.255.0
TELKOM_UNIVERSITY(config-if)#no shut
TELKOM_UNIVERSITY(config-if)#^Z
TELKOM_UNIVERSITY#
____________________________________________________________

6. Setting default gateway
gateway yang digunakan adalah 10.123.1.1
___________________________________________________
TELKOM_UNIVERSITY#conf t
TELKOM_UNIVERSITY(config)#ip default-gateway 10.123.1.1
TELKOM_UNIVERSITY(config-if)#^Z
TELKOM_UNIVERSITY#
___________________________________________________


7. Setting interface seluruh port LAN untuk user
Switch ini di peruntukkan untuk user yang dimasukkan dalam vlan 2. Pembuatan vlan dan vlan database ada pada pembahasan lainnya.
Vlan ini harus sudah di buat terlebih dahulu agar port interfacenya dapat di konfigure switch access ke vlan tersebut.
__________________________________________________________
TELKOM_UNIVERSITY#
TELKOM_UNIVERSITY#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
TELKOM_UNIVERSITY(config)#int range gi1/0/1 - 23
TELKOM_UNIVERSITY(config-if-range)#switchport mode access
TELKOM_UNIVERSITY(config-if-range)#swit acce vlan 2
TELKOM_UNIVERSITY(config-if-range)#no shut
TELKOM_UNIVERSITY(config-if-range)#^Z
TELKOM_UNIVERSITY#
__________________________________________

8. Setting interface 1 port untuk line trunk
Disini kita menggunakan port no 24 sebagai port untuk trunk koneksi ke switch lainnya.
__________________________________________________
TELKOM_UNIVERSITY#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
TELKOM_UNIVERSITY(config)#int gi1/0/24
TELKOM_UNIVERSITY(config-if)#switchport trunk encap dot1q
TELKOM_UNIVERSITY(config-if)#switchport mode trunk
TELKOM_UNIVERSITY(config-if)#no switchport mode access
TELKOM_UNIVERSITY(config-if)#no shut
TELKOM_UNIVERSITY(config-if)#^Z
TELKOM_UNIVERSITY#
____________________________________________________

9. Membuat banner switch
Banner ini hanya label, boleh dibuat boleh tidak, bedakan labelnya untuk tiap2 switch jika label ini dijadikan sebagai tanda masing-masing switch.
____________________________________________________________________
TELKOM_UNIVERSITY#
TELKOM_UNIVERSITY#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
TELKOM_UNIVERSITY(config)#banner motd "TELKOM UNIVERSITY SWITCH LAB 1"
TELKOM_UNIVERSITY(config)#^Z
TELKOM_UNIVERSITY#
_____________________________________________________________________

10. Simpan konfigurasi.
Lakukan penyimpanan konfigurasi yang telah dilakukan.
________________________________
TELKOM_UNIVERSITY#
TELKOM_UNIVERSITY#wr mem
Building configuration...
[OK]
TELKOM_UNIVERSITY#
________________________________


11. Testing

Mari kita flash back hasil konfigurasi yang kita lakukan tadi dengan command #sh run.
_________________________________________________
TELKOM_UNIVERSITY#sh run
Building configuration...

Current configuration : 2946 bytes

!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname TELKOM_UNIVERSITY
!
boot-start-marker
boot-end-marker
!
enable password telkom
!
no aaa new-model
switch 3 provision ws-c3750g-24ps
system mtu routing 1500
ip subnet-zero
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
interface GigabitEthernet1/0/1
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet1/0/2
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet1/0/3
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet1/0/4
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet1/0/5
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet1/0/6
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet1/0/7
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet1/0/8
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet1/0/9
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet1/0/10
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet1/0/11
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet1/0/12
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet1/0/13
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet1/0/14
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet1/0/15
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet1/0/16
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet1/0/17
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet1/0/18
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet1/0/19
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet1/0/20
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet1/0/21
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet1/0/22
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet1/0/23
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk

!

interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface Vlan1
 ip address 10.123.1.10 255.255.255.0
!
interface Vlan9
 no ip address
!
ip default-gateway 10.123.1.1
ip classless
ip http server
ip http secure-server
!
!
!
!
control-plane
!
banner motd ^CTELKOM UNIVERSITY SWITCH LAB 1^C
!
line con 0
 password telkom
line vty 0 4
 password telkom
 login
line vty 5 15
 password telkom
 login
!
end

TELKOM_UNIVERSITY#
_________________________________________________

Yang perlu diingat:

Untuk testing koneksi ke switch lain, kita bisa melakukan konfigurasi yang sama pada cisco switch lain dengan merubah hostname dan IP addressnya.

Konfigurasi ini tidak serta merta membuat komputer/ laptop/printer mendapatkan IP address, tetap dibutuhkan DHCP server / router yang akan mengalokasikan IP address.

Selamat mencoba.

Posted By Dewi Angraini10.19

Senin, 27 Oktober 2014

Internet Port TCP and UDP

Filled under:

Berbicara tentang teknologi internet dan aplikasinya tidaklah lepas dari yang namanya port TCP dan port TDP.
Penjelasan mengenai apa itu TCP dan UDP banyak di dapat di berbagai link di internet, yang pasti keduanya adalah protokol internet. Dari berbagai literatur dijelaskan bahwa protokol TCP adalah protokol yang digunakan untuk metode transmisi yang terhubung langsung ke komputer sementara protokol TDP tidak demikian.

Ilustrasinya begini, setiap komputer atau perangkat di Internet harus memiliki alamat IP . Alamat IP ini digunakan untuk mengenali komputer tertentu dari jutaan komputer lain yang terhubung ke internet . Ketika informasi dikirim melalui internet ke komputer anda, bagaimana komputer anda menerima informasi itu? nah komputer tersebut akan menilai apakah informasi tersebut diterima menggunakan TCP atau UDP.

Anda dapat memiliki total 65.535 Port TCP dan total 65.535 Port UDP.


Internet TCP and UDP port

Berikut berapa contoh port TCP dan UDP yang banyak digunakan secara official dan unofficial.

Silahkan klik disini


Posted By Dewi Angraini12.23

Preservation Digital Forensic

Filled under: ,

Dalam beberapa tahun terakhir, digital forensic muncul sebagai salah satu bahan pembuktian dalam pendekatan untuk memfasilitasi kurasi dan kelestarian daripada materi digital terutama dalam memproteksi dan investigasi barang bukti dari masa lalu.

Dibutuhkan sebuah institusi penyimpanan yang profesional dengan tanggung jawab dalam penyimpanan dan penanganan keaslian daripada arsip digital.

Informasi digital ini harus ditangani dengan sangat sensitiv dan dalam penjagaan maksimum karena merupakan barang bukti yang otentik.


Teknologi digital forensik ini memungkinkan kita untuk:
1. mengidentifikasi isu-isu pribadi,
2. melacak kondisi asal dari sebuah isu.
3. mendeteksi pemalsuan atau manipulasi,
4. memfasilitasi kontrol audit
5. dan lainnya.

Forensik digital dikaitkan dalam pikiran banyak orang terutama dengan penyelidikan kejahatan.
Namun saat ini Digital Forensic banyak digunakan khusus untuk melindungi dan menyelidiki bukti dari masa lalu.

Ada tiga prinsip dasar yang penting dalam forensik digital:
1. bahwa bukti tersebut diperoleh tanpa mengubah aslinya,
2. bahwa ini adalah terbukti begitu
3. dan analisis yang dilakukan secara akuntabel dan cara berulang.


Posted By Dewi Angraini11.10

Information Security management

Filled under: ,

Faktor yang paling penting dalam melindungi aset informasi dan privasi adalah meletakkan dasar manajemen keamanan informasi yang efektif.

Adalah penting untuk menyadari bahwa tujuan daripada security management tersebut sangat diperlukan.

Information Security Management  yang terkadang disingkat menjadi InfoSec , adalah praktek membatasi informasi, penggunaan, pengungkapan , gangguan , modifikasi , teliti , inspeksi , rekaman atau perusakan dari akses yang tidak sah.

Information Security Management

Istilah umumnya dapat dikatakan perlakuan proteksi terhadap sesuatu yang digunakan terlepas dari bentuk perangkat elektronik, fisik, dan non fisik dari tindakan ilegal.Dua aspek utama dari Information Security adalah :

1. Keamanan IT :

Biasanya disebut sebagai keamanan komputer. Information Security Management diterapkan pada teknologi (paling sering beberapa bentuk sistem komputer ), hal ini berguna untuk dicatat bahwa komputer tidak selalu berarti sebuah desktop rumah . Sebuah komputer adalah perangkat dengan prosesor dan beberapa memori ( bahkan kalkulator ).

Spesialis keamanan IT hampir selalu ditemukan di setiap perusahaan / usaha  karena sifat dan nilai dari data di dalam bisnis yang lebih besar. Mereka bertanggung jawab untuk menjaga semua teknologi dalam perusahaan agar aman dari serangan cyber berbahaya yang sering mencoba untuk melakukan tindakan ilegal.

2. Jaminan Informasi :

Tindakan memastikan bahwa data tidak hilang ketika isu-isu kritis muncul . Isu-isu ini  tidak terbatas pada : bencana alam, kerusakan komputer / server, pencurian fisik, atau contoh lain di mana data memiliki potensi hilang karena di era modern ini sebagian besar informasi disimpan pada kompute. Jaminan informasi biasanya ditangani oleh para ahli keamanan IT.

Salah satu metode yang paling umum adalah memberikan jaminan informasi dengan memiliki backup off-site untuk mengatasi munculnya masalah-masalah yang disebutkan diatas. Saat ini telah banyak penyedia jasa data center dalam hal mengatasi jaminan informasi.Pemerintah, militer, perusahaan, lembaga keuangan, rumah sakit, dan perusahaan swasta mengumpulkan banyak informasi rahasia tentang  karyawan mereka, pelanggan, produk, penelitian dan bahkan  status keuangan. Sebagian besar informasi ini sekarang dikumpulkan, diolah dan disimpan pada komputer elektronik dan dikirimkan melalui jaringan ke komputer lain .

Haruskah informasi rahasia tentang pelanggan bisnis atau keuangan atau lini produk baru jatuh ke tangan pesaing atau hacker ?, bisnis dan pelanggan bisa menderita yang sangat fatal hingga kerugian keuangan, belum lagi kerusakan pada reputasi perusahaan . Melindungi informasi rahasia adalah kebutuhan bisnis dan dalam banyak kasus juga merupakan persyaratan etika dan hukum .

Tindakan memastikan bahwa data tidak hilang ketika isu-isu kritis muncul . Isu-isu ini  tidak terbatas pada : bencana alam, kerusakan komputer / server, pencurian fisik, atau contoh lain di mana data memiliki potensi hilang karena di era modern ini sebagian besar informasi disimpan pada kompute. Jaminan informasi biasanya ditangani oleh para ahli keamanan IT.

Salah satu metode yang paling umum adalah memberikan jaminan informasi dengan memiliki backup off-site untuk mengatasi munculnya masalah-masalah yang disebutkan diatas. Saat ini telah banyak penyedia jasa data center dalam hal mengatasi jaminan informasi.Pemerintah, militer, perusahaan, lembaga keuangan, rumah sakit, dan perusahaan swasta mengumpulkan banyak informasi rahasia tentang  karyawan mereka, pelanggan, produk, penelitian dan bahkan  status keuangan. Sebagian besar informasi ini sekarang dikumpulkan, diolah dan disimpan pada komputer elektronik dan dikirimkan melalui jaringan ke komputer lain .

Haruskah informasi rahasia tentang pelanggan bisnis atau keuangan atau lini produk baru jatuh ke tangan pesaing atau hacker ?, bisnis dan pelanggan bisa menderita yang sangat fatal hingga kerugian keuangan, belum lagi kerusakan pada reputasi perusahaan . Melindungi informasi rahasia adalah kebutuhan bisnis dan dalam banyak kasus juga merupakan persyaratan etika dan hukum .

Apakah perusahaan atau organisasi anda perlu meningkatkan Information Security Management?

Posted By Dewi Angraini11.04

Mengatasi Loading lama pada website

Filled under: , ,

Mungkin kita sering megalami loding yang sangat lama pada saat mengunjungi sebuah website. Menyebalkan bukan?
Hal ini disebabkan karena website tersebut harus meloading beberapa source file yang akan ditampilkan seperti logo, file css, flash file dan lain-lain. Jika website yang anda kunjungi hanya menampilkan text saja maka loading lama ini tidak akan terjadi, tapi keindahan website tidak akan didapat jika hanya menampilkan text saja.
Nah bagaimana jika ini terjadi pada website anda yang dikunjungi orang ?
Kalau si visitor sabar dan memang membutuhkan informasi dari website anda dia pasti akan menunggu, namun kebanyakan akan langsung menutup dan mencari informasi dari website lain.

Bagaimana cara mengatasi loading lama pada website ini?
Anda perlu melakukan browser caching karena browser caching ini dilakukan untuk mengingat source file yang diload dari website anda. Artinya untuk loading page halaman-halaman yang memuat source file yang sama website tersebut tidak akan meload ulang file-file tersebut.
Salah satu cara melakukan browser caching ini dapat dilakukan dengan membuat atau memasukkan code dibawah kedalam file .htaccess website anda.

## EXPIRES CACHING ##

ExpiresActive On
ExpiresByType image/jpg "access 1 year"
ExpiresByType image/jpeg "access 1 year"
ExpiresByType image/gif "access 1 year"
ExpiresByType image/png "access 1 year"
ExpiresByType text/css "access 1 month"
ExpiresByType text/html "access 1 month"
ExpiresByType application/pdf "access 1 month"
ExpiresByType text/x-javascript "access 1 month"
ExpiresByType application/x-shockwave-flash "access 1 month" ExpiresByType image/x-icon "access 1 year"
ExpiresDefault "access 1 month"

## EXPIRES CACHING ##


Anda dapat menambahkan jenis source file yang anda inginkan yang belum tertulis diatas.

Selamat mencoba.

Posted By Dewi Angraini08.39

Kamis, 23 Oktober 2014

Information Security management

Filled under: , ,

Faktor yang paling penting dalam melindungi aset informasi dan privasi adalah meletakkan dasar manajemen keamanan informasi yang efektif. 

Adalah penting untuk menyadari bahwa tujuan daripada security management tersebut sangat diperlukan.

Information Security Management  yang terkadang disingkat menjadi InfoSec , adalah praktek membatasi informasi, penggunaan, pengungkapan , gangguan , modifikasi , teliti , inspeksi , rekaman atau perusakan dari akses yang tidak sah.

Information Security Management

Istilah umumnya dapat dikatakan perlakuan proteksi terhadap sesuatu yang digunakan terlepas dari bentuk perangkat elektronik, fisik, dan non fisik dari tindakan ilegal.Dua aspek utama dari Information Security adalah :

1. Keamanan IT :

Biasanya disebut sebagai keamanan komputer. Information Security Management diterapkan pada teknologi (paling sering beberapa bentuk sistem komputer ), hal ini berguna untuk dicatat bahwa komputer tidak selalu berarti sebuah desktop rumah . Sebuah komputer adalah perangkat dengan prosesor dan beberapa memori ( bahkan kalkulator ). 

Spesialis keamanan IT hampir selalu ditemukan di setiap perusahaan / usaha  karena sifat dan nilai dari data di dalam bisnis yang lebih besar. Mereka bertanggung jawab untuk menjaga semua teknologi dalam perusahaan agar aman dari serangan cyber berbahaya yang sering mencoba untuk melakukan tindakan ilegal.

2. Jaminan Informasi :

Tindakan memastikan bahwa data tidak hilang ketika isu-isu kritis muncul . Isu-isu ini  tidak terbatas pada : bencana alam, kerusakan komputer / server, pencurian fisik, atau contoh lain di mana data memiliki potensi hilang karena di era modern ini sebagian besar informasi disimpan pada kompute. Jaminan informasi biasanya ditangani oleh para ahli keamanan IT.

Salah satu metode yang paling umum adalah memberikan jaminan informasi dengan memiliki backup off-site untuk mengatasi munculnya masalah-masalah yang disebutkan diatas. Saat ini telah banyak penyedia jasa data center dalam hal mengatasi jaminan informasi.Pemerintah, militer, perusahaan, lembaga keuangan, rumah sakit, dan perusahaan swasta mengumpulkan banyak informasi rahasia tentang  karyawan mereka, pelanggan, produk, penelitian dan bahkan  status keuangan. Sebagian besar informasi ini sekarang dikumpulkan, diolah dan disimpan pada komputer elektronik dan dikirimkan melalui jaringan ke komputer lain .

Haruskah informasi rahasia tentang pelanggan bisnis atau keuangan atau lini produk baru jatuh ke tangan pesaing atau hacker ?, bisnis dan pelanggan bisa menderita yang sangat fatal hingga kerugian keuangan, belum lagi kerusakan pada reputasi perusahaan . Melindungi informasi rahasia adalah kebutuhan bisnis dan dalam banyak kasus juga merupakan persyaratan etika dan hukum .

Tindakan memastikan bahwa data tidak hilang ketika isu-isu kritis muncul . Isu-isu ini  tidak terbatas pada : bencana alam, kerusakan komputer / server, pencurian fisik, atau contoh lain di mana data memiliki potensi hilang karena di era modern ini sebagian besar informasi disimpan pada kompute. Jaminan informasi biasanya ditangani oleh para ahli keamanan IT.

Salah satu metode yang paling umum adalah memberikan jaminan informasi dengan memiliki backup off-site untuk mengatasi munculnya masalah-masalah yang disebutkan diatas. Saat ini telah banyak penyedia jasa data center dalam hal mengatasi jaminan informasi.Pemerintah, militer, perusahaan, lembaga keuangan, rumah sakit, dan perusahaan swasta mengumpulkan banyak informasi rahasia tentang  karyawan mereka, pelanggan, produk, penelitian dan bahkan  status keuangan. Sebagian besar informasi ini sekarang dikumpulkan, diolah dan disimpan pada komputer elektronik dan dikirimkan melalui jaringan ke komputer lain .

Haruskah informasi rahasia tentang pelanggan bisnis atau keuangan atau lini produk baru jatuh ke tangan pesaing atau hacker ?, bisnis dan pelanggan bisa menderita yang sangat fatal hingga kerugian keuangan, belum lagi kerusakan pada reputasi perusahaan . Melindungi informasi rahasia adalah kebutuhan bisnis dan dalam banyak kasus juga merupakan persyaratan etika dan hukum .

Apakah perusahaan atau organisasi anda perlu meningkatkan Information Security Management

Posted By Dewi Angraini09.27

IT infrastructure library (ITIL)

Filled under: ,

IT Infrastructure Library atau yang biasa disingkat ITIL memiliki inti yang masing-masing memerikan bimbingan yang diperlukan dalam pendekatan terpadu, sebagaimana dibutuhkan sebagai standarisasi ISO / IEC 20000 adalah:

1. Service strategy (strategy pelayanan)
2. Service design (layanan desain) yang meliputi:
3. Service transition (layanan transisi)
4. Service operation (layanan operasi)
5. Continual service improvement (peningkatan pelayanan berkelanjutan)

Silahkan klik pada tiap-tiap nomor untuk pembahasan lanjutan.

Posted By Dewi Angraini09.23